Atuin stopped working

I installed successfully and it was initially within my Ubuntu WSL (Windows) installation but now commands don’t seem to be searchable or showing up in my history. Using bash environment. What information do you need from me to troubleshoot?

Also noticed that Atuin is only showing commands from > 3d ago?

I’m just another user but I may be able to help as I also used to use bash, can you check your .bashrc and send the part related to atuin.

For me it was

[[ -f ~/ ]] && source ~/
eval "$(atuin init bash)"

If you can also check the version of atuin you have that would be great, the output of atuin -V.

If you could also share

  • bash version
  • full details of your Atuin install
  • has anything changed since it last worked? did you update anything?

bash version

$ (master) bash -version
GNU bash, version 5.0.17(1)-release (x86_64-pc-linux-gnu)
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>


bash <(curl --proto '=https' --tlsv1.2 -sSf


# initialize Atuin, shell history search tool and sync
eval "$(atuin init bash --disable-up-arrow)"

has anything changed since it last worked? did you update anything?

  • nothing changed

Hi sorry @bimp was you issue resolved or do you still need help?

sorry haven’t come back to this… i kind of punted on this since I haven’t heard back since my last reply but yeah still have issues although I haven’t tried using it lately

Do you mind trying zsh and see if you still have the problem?

These are my notes (they are pretty basic) from when I switched over from bash. Overall I really like zsh and bonus I have no issues with atuin when using zsh.

And this is a copy of my .zshrc

# Turn on comments for commands executed from the command line so they can show in history
setopt interactivecomments
eval "$(atuin init zsh)"

The interactive comments allow me to save comments along with my commands so I can find them easier in the future.

Not OP, but wanted to say: TIL, thanks!

It looks like you don’t have bash-preexec setup in your config, from what you’ve shared previously (though the script should have set it up)

You’re welcome, I’ll thank bash for that one. I was using that “feature” in bash until I switched to zsh and it didn’t work by default. So turned it on and life is good again. Searching by comment is so much easier.